Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Topic Options
Rate This Topic
#290512 - 2020-01-16 10:11 G98 turn-on/boot-up failure
Registered: 2014-11-20
Posts: 12
DrPeter Offline
Harmless
DrPeter Offline
Harmless

Registered: 2014-11-20
Posts: 12
Loc: Chepstow, Monmouthshire, UK
Hi. I'm looking for a little help with a G98 DVD-Audio/Video/CD player. I've owned this unit from new and bought it sometime in the mid/late noughties, so it's fairly old now. Basically the unit powers down almost immediately after it has powered up, returning to standby. It does exactly the same whether I power up using the on/off button or using the drawer 'open' button.

The exact sequence of events is as follows:

If the unit is turned on using the mains switch on the rear, it powers up as it normally would in that case, i.e. the display comes on, with the Meridian logo, the DVD-ROM drive whirs a little and then the unit goes into standby. So far as I recall, this is absolutely as normal.

If the power button on the front panel is then pressed, the display again comes on, with the Meridian logo and then changes to the 'play', 'stop' etc. symbols (again, as normal). It then reads either 'loading' or 'open' briefly (for 1 second or so), depending upon whether it was the 'power' or 'open' button which was used to turn the unit on. Simultaneously, the DVD-ROM drive spins up a couple of times (there is no disk in the tray) - I've taken the cover off and can see the 'hub' at the centre of the drive spinning briefly and the laser lighting up (red glow). The unit then returns to standby. If the 'on' button is pressed again, the same sequence repeats.

I've tested the power supply during this process and the +5V and +/-12V lines seem fine (the +12V line reads +13V, dipping to about 12.8V when the drive spins up, if this is significant?). I've had a power supply fail on a G68 (and replaced it successfully), so I'm aware that these can be a weakness.

Does the above indicate a problem with the DVD ROM drive (i.e. it fails some form of self-test)? If so, any idea which of the two options (DVS-720 or DRL-200) is likely to have been fitted to the unit? It doesn't stay 'up' long enough for me to check which firmware version is loaded, which I believe is the clincher in regard to which DVD drive should be fitted?

Any suggestions as to what to check/replace would be very welcome. I'm confident with electronics and have some useful test gear (e.g. an oscilloscope or three), if any such would be useful in diagnosing the fault.


G68ADV, G98DH
Top
#290513 - 2020-01-16 10:35 Re: G98 turn-on/boot-up failure [Re: DrPeter]
Registered: 2004-01-20
Posts: 784
Chris G Offline
Paranoid android
Chris G Offline
Paranoid android

Registered: 2004-01-20
Posts: 784
Loc: Newbury, UK
What does the +5v rail read?


Chris
 AV Room: G61R | HD621 | 4xD5K + D5KC | USC15 - iNuke6K | GIK 242s | Crowson T108SS | Pioneer 5090 | JVC HD950 & 1.9m React3 2.4:1 screen
Top
#290515 - 2020-01-16 11:01 Re: G98 turn-on/boot-up failure [Re: Chris G]
Registered: 2014-11-20
Posts: 12
DrPeter Offline
Harmless
DrPeter Offline
Harmless

Registered: 2014-11-20
Posts: 12
Loc: Chepstow, Monmouthshire, UK
It reads: +5.2V and this stays constant throughout the 'boot-up' process.

Peter


G68ADV, G98DH
Top
#290516 - 2020-01-16 11:21 Re: G98 turn-on/boot-up failure [Re: DrPeter]
Registered: 2005-05-11
Posts: 104
swpnt Online content
Hitchhiker
swpnt Online content
Hitchhiker

Registered: 2005-05-11
Posts: 104
Loc: Woking, Surrey, UK
I doubt its an issue with the drive, more likely the PSU and capacitors on the power board (next to the PSU).

I have had PSUs read correct voltages but fail to deliver required current when called upon.

I would replace both the power supply and capacitors and see if that resolves the issue.

Good luck,

Steve


Main: 861v4 (LPS), 808.3, HD621, DSP6k, DSP5200HC, DSP33, SW1600, MC200,Sky HD, Cambridge Audio BD, C10
Office: 818v3, 800v4, 557, MF MC2s, Mac Mini
Office2: 561, M3, M2500
Spare: 100 Series,200 Series,500 Series, M60, M60C, DSP5k(s), DSP5kC, C15
Top
#290517 - 2020-01-16 11:33 Re: G98 turn-on/boot-up failure [Re: swpnt]
Registered: 2014-11-20
Posts: 12
DrPeter Offline
Harmless
DrPeter Offline
Harmless

Registered: 2014-11-20
Posts: 12
Loc: Chepstow, Monmouthshire, UK
OK, thanks Steve. I'll take a look in that area.

Peter


G68ADV, G98DH
Top

Moderator:  Carl, Duncs, ncpl 
Who's Online
4 registered (Step635, Mr_Gimlet, Krazywaffle, OldDogCan), 60 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
Xebxorro, LeonardoDelgado, SunValleyLaw, PaulMichaelMiller, Earfully
4820 Registered Users
Top Posters (30 Days)
Mike_500 43
Ratbert 38
CMB Integrations - Bruce 20
spinaltap 20
3dit0r 18
Top Posters
VirusKiller 12640
Fiddler 8672
ncpl 8577
Carl 8005
Ian 7866
Forum Stats
4,820 Registered Members
18 Forums
26,893 Topics
268,797 Posts

Most users ever online: 607 @ 2020-01-20 17:19
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant