Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Topic Options
Rate This Topic
#282644 - 2019-02-09 19:16 Meridian M60 and 568 problems
Registered: 2019-02-07
Posts: 2
Goatiebaby Offline
Harmless
Goatiebaby Offline
Harmless

Registered: 2019-02-07
Posts: 2
Loc: Reading, Berks, England
First off I should introduce myself; my name is Steve and I'm a volunteer with Oxfam at their music shop in Reading. I normally do the PAT testing on donated items and have recently had a very nice donation of hifi from a local dealer of their surplus second hand stock. The problem I have is with getting a pair of M60 speakers (Mk. 1's with phono and balanced inputs) and a 568 processor to work. Originally the 568 would not turn on but that was solved by putting in a replacement main fuse which was not present and this seems to function fine, and I have configured it for 2 channel analogue output with no subwoofer. I have rigged it up with my Naim CD player as a source, and connected it to the M60's and we have music. The problem is that after 30 seconds or so each speaker starts clicking every second or so and at the same time the green LED on the front panel flashes at the same frequency! The music continues to play without interruption and the clicking doesn't increase with volume so you can drown it out by turning the amp up but it never disappears. I thought that it might be a problem with the settings on the 568 but they seem okay and bizarrely the clicking continues even if the 568 is turned off and the phono leads are disconnected!
Sorry for the long-winded post but I am hoping that having explained this thoroughly someone on your forum might be able to offer a solution as we were hoping to raise several hundred pounds from the sale of these.
Cheers Steve

Top
#282646 - 2019-02-09 20:00 Re: Meridian M60 and 568 problems [Re: Goatiebaby]
Registered: 2005-05-11
Posts: 55
swpnt Offline
Mostly harmless
swpnt Offline
Mostly harmless

Registered: 2005-05-11
Posts: 55
Loc: Woking, Surrey, UK
Hi Steve and welcome to the forum.

It sounds like the fault is probably with the M60 speakers. I would assume that they may need a service.
The M60s (and their digital counterparts - DSP5000s) tend to suffer from failed load resistors and dried out capacitors. Depending on how handy you are with a soldering iron, they can be repaired.

If you search the forums for DSP5000 servicing then you should come across Tarik's excellent guide. This should apply to the M60s (as they use the same amplifier boards). He may also be able to supply a kit of components to sort out the problems.

Good luck - sounds like you have a system worth saving.

Cheers,

Steve


Main: 861v4 (LPS),800v4,HD621,DSP6k,DSP5200HC,DSP33,C15,Apple TV,Sky HD,Cambridge Audio BD
Office: 818v3,800v3,504,557,MF MC2s,Mac Mini
Office2: 561,M3
G68J,G98DH
Spare: 101,104,201,204,207,208,M60,M60C,518,506,555,568.2MM,598DP,DSP5k(s),DSP5kC
Top
#282647 - 2019-02-09 20:26 Re: Meridian M60 and 568 problems [Re: Goatiebaby]
Registered: 2008-10-11
Posts: 470
Tarik Offline
Paranoid android
Tarik Offline
Paranoid android

Registered: 2008-10-11
Posts: 470
Loc: Gloucestershire, UK
Hi Steve,

Probably easier for you to give me a call to discuss. I'd be happy to help.

PM sent with contact details


Lounge: DSP5200, 518
Snug: DSP33 x 5, 518, C61R
Office: M33

Top
#282754 - 2019-02-13 21:26 Re: Meridian M60 and 568 problems [Re: Tarik]
Registered: 2019-02-07
Posts: 2
Goatiebaby Offline
Harmless
Goatiebaby Offline
Harmless

Registered: 2019-02-07
Posts: 2
Loc: Reading, Berks, England
Just a quick note to say thank you to folks on this forum for indulging me. Didn't solve the problem but having contacted Tariq as suggested we have done a deal and he is now in possession of these with a view to fixing them himself.

Cheers Steve

Top
#282755 - 2019-02-13 22:44 Re: Meridian M60 and 568 problems [Re: Goatiebaby]
Registered: 2018-08-04
Posts: 66
MrTechGuy Online content
Mostly harmless
MrTechGuy Online content
Mostly harmless

Registered: 2018-08-04
Posts: 66
Loc: Cambridgeshire, UK
Hi

If Tarik fails to repair these we do have spares for them and have just completed a set recently for a customer.

Regards
Edd


Repairs, Upgrades, Spares and System Setup.
http://www.mrtechguy.co.uk

Factory Authorised Meridian Repair Centre
Top

Moderator:  Carl, Duncs, ncpl 
Who's Online
4 registered (Maz, bxd, Richard W, Kal Rubinson), 49 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
LionHo, Akeemolee, Cambam, Blotto723, Mvukic
4745 Registered Users
Top Posters (30 Days)
3dit0r 57
CMB Integrations - Bruce 51
KTMsteve 42
Ian 41
Ratbert 40
Top Posters
VirusKiller 12494
Fiddler 8672
ncpl 8496
Carl 7881
Ian 7733
Forum Stats
4,745 Registered Members
18 Forums
26,127 Topics
262,562 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant