Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Page 2 of 3 < 1 2 3 >
Topic Options
Rate This Topic
#274449 - 2018-03-22 06:22 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2010-12-09
Posts: 3,546
Ratbert Offline
Ravenous Bugblatter Beast of Traal
Ratbert Offline
Ravenous Bugblatter Beast of Traal

Registered: 2010-12-09
Posts: 3,546
Loc: Europe
It is most likely the power supply as already discussed, have a read of this wiki document on G68 PSU replacement if it scares you then you need to find a friend or a repair shop to do it for you.


Never pass up a good chance to shut up!
Top
#274450 - 2018-03-22 07:40 Re: G68 switching on & off? [Re: Ratbert]
Registered: 2004-08-07
Posts: 7,551
Ian Offline
President of the Imperial Galactic Government
Ian Offline
President of the Imperial Galactic Government

Registered: 2004-08-07
Posts: 7,551
Loc: Surrey, England, UK
May also be worth getting connectors and cards checked that they are still seated properly. Wont be the first time that something previously working didn't after being transported.


Meridian owner since 1992
DSP5000 96/24, MC200, Prime & PSU, Focal Elear, Explorer 1 & 2, F80, 200/203 and various Sonos.
Top
#274452 - 2018-03-22 13:02 Re: G68 switching on & off? [Re: Ian]
Registered: 2015-03-16
Posts: 73
Laserblues2 Offline
Mostly harmless
Laserblues2 Offline
Mostly harmless

Registered: 2015-03-16
Posts: 73
Loc: Hong Kong
Happy to get a friend to help - just wanted to show the guy I bought it from the issue so he doesn't think I'm just trying it on. Will try again tomorrow and just video whatever it does.

Will open it up and take a look smile

Thanks for the advice and help, sorry for lots of questions.


G55, G68XXV, HD621, Oppo 105D, MacBook running Roon
Top
#274794 - 2018-04-05 04:25 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2015-03-16
Posts: 73
Laserblues2 Offline
Mostly harmless
Laserblues2 Offline
Mostly harmless

Registered: 2015-03-16
Posts: 73
Loc: Hong Kong
Massive thank you to SteveM! Managed to get the G68 up & running again last night!! Relieved to discover nothing else is damaged, thank you so much for your time & advice!


G55, G68XXV, HD621, Oppo 105D, MacBook running Roon
Top
#274795 - 2018-04-05 07:40 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2004-08-07
Posts: 7,551
Ian Offline
President of the Imperial Galactic Government
Ian Offline
President of the Imperial Galactic Government

Registered: 2004-08-07
Posts: 7,551
Loc: Surrey, England, UK
And the problem was? PSU?


Meridian owner since 1992
DSP5000 96/24, MC200, Prime & PSU, Focal Elear, Explorer 1 & 2, F80, 200/203 and various Sonos.
Top
#274830 - 2018-04-06 06:41 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2016-11-27
Posts: 192
Struttmaster Offline
Hitchhiker
Struttmaster Offline
Hitchhiker

Registered: 2016-11-27
Posts: 192
Loc: Gold Coast, Queensland, Austra...
Curious too, did you replace the ps or tweak it?


HT: G68ADV w/LPS, HD621, DSP5000 F&C 24/96, DSP3100, Allo digi
Office: Fanless 7i5 running ROCK, 218, Woo Audio WA2 (w/50yo Tung-Sol tubes), Focal Utopia
Family Room. Grandinote Volta, Ultra rendu w/LPS 1.2, Prime with PSU, Grandinote Shinai
Bedroom: MRendu w/IsoREGEN, 568.2mm, 598, 3100C
BBQ/Party: Raspberry Pi, Explorer 2, F80
Top
#274879 - 2018-04-07 10:01 Re: G68 switching on & off? [Re: Struttmaster]
Registered: 2015-03-16
Posts: 73
Laserblues2 Offline
Mostly harmless
Laserblues2 Offline
Mostly harmless

Registered: 2015-03-16
Posts: 73
Loc: Hong Kong
Yes, replaced the PSU & all has been so far!

Just been trying to get the comms ports to work to use the configuration software. The RS232 never worked so ended up using a USB cable which has worked but can’t access the HD621. Wondering if there’s really any value in connecting to it as the G68 seems capable of doing everything?!

So grateful for all the replies & advice on here, and Steve’s help has been amazing!


G55, G68XXV, HD621, Oppo 105D, MacBook running Roon
Top
#274880 - 2018-04-07 11:16 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2006-11-08
Posts: 4,007
dpstjp Offline
Vogon Civil Servant
dpstjp Offline
Vogon Civil Servant

Registered: 2006-11-08
Posts: 4,007
Loc: London, England
Are you sure the serial cable you were using was a null modem cable? Did you allocate a comms port to it?


Sooloos, Roon, G series (with LPS upgrade), 800 series (with LPS upgrade), HD621, AC200, Prime and PS, DSPs old and new.

Purdeys, Moke, Leica, 'Blad. Only the best.
Top
#274906 - 2018-04-07 21:59 Re: G68 switching on & off? [Re: dpstjp]
Registered: 2015-03-16
Posts: 73
Laserblues2 Offline
Mostly harmless
Laserblues2 Offline
Mostly harmless

Registered: 2015-03-16
Posts: 73
Loc: Hong Kong
Not sure, it’s a Unitek Y-105 USB to serial cable. I’ll check and see, as that would make most sense that the cable had a problem


G55, G68XXV, HD621, Oppo 105D, MacBook running Roon
Top
#274916 - 2018-04-08 08:32 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2004-08-07
Posts: 7,551
Ian Offline
President of the Imperial Galactic Government
Ian Offline
President of the Imperial Galactic Government

Registered: 2004-08-07
Posts: 7,551
Loc: Surrey, England, UK
No mention in the spec that it has (rare feature) integrated null modem (crossover) capabilities so suspect that you need an additional 'null modem' cable to internally crossover tx/rx.


Meridian owner since 1992
DSP5000 96/24, MC200, Prime & PSU, Focal Elear, Explorer 1 & 2, F80, 200/203 and various Sonos.
Top
#274969 - 2018-04-09 14:58 Re: G68 switching on & off? [Re: Ian]
Registered: 2015-03-16
Posts: 73
Laserblues2 Offline
Mostly harmless
Laserblues2 Offline
Mostly harmless

Registered: 2015-03-16
Posts: 73
Loc: Hong Kong
Cool - thanks!

Do I just need a null modem cable, or do I need another USB to RS232 cable? (Sorry newbie with all this stuff.)

Would one of these be ok?

Maybe this VIDEK ONE?


G55, G68XXV, HD621, Oppo 105D, MacBook running Roon
Top
#274987 - 2018-04-09 22:45 Re: G68 switching on & off? [Re: Laserblues2]
Registered: 2008-05-23
Posts: 7,777
Carl Online content
President of the Imperial Galactic Government
Carl Online content


President of the Imperial Galactic Government

Registered: 2008-05-23
Posts: 7,777
Loc: Central England, UK
Just adding a NULL modem cable into the chain should be fine.

Can never be 100% certain but that VIDEK one should do the job.

Regards,
Carl


861v6+ID40, HD621, 8000.2, 7200HC, 7200, SKYQ Silver, PS3, PDP-LX6090, QNAP TS870-Pro (8*6TB), Roon, iPadAir2.
[In Reserve] C15, MD600 (2*3TB), TwinStore RM (2*2TB)
Top
Page 2 of 3 < 1 2 3 >

Moderator:  Carl, Duncs, ncpl 
Who's Online
8 registered (Carl, Cmr600, Kswanson, AudioImages - Rick, ChrisLayerUK, MacGuy), 50 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
ClausM, Brightk, ralphfcooke, Mario, Myles
4675 Registered Users
Top Posters (30 Days)
spinaltap 45
D4ve84 39
Ian 28
Mr Meridian 19
VirusKiller 19
Top Posters
VirusKiller 12406
Fiddler 8667
ncpl 8469
Carl 7777
Ian 7551
Forum Stats
4,675 Registered Members
18 Forums
25,492 Topics
257,613 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant