Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Topic Options
Rate This Topic
#271495 - 2018-01-06 23:00 G65 freezes up occasionally
Registered: 2007-09-17
Posts: 30
Snooky Offline
Harmless
Snooky Offline
Harmless

Registered: 2007-09-17
Posts: 30
My G65 will occasionally freeze up. It's not completely locked when this happens, but rather extremely slow to respond to any commands except power off. Changing source, adjusting volume etc. is possible, but it takes up to a minute from button press to actual response. Also when in this state all sound is off.

Only way I've discovered to recover from this is to power toggle the G65. Usually all speakers will emit a loud noise just before the unit is completely off. When I turn it back on again all seems normal.

I'm unable to predict when this freeze will occur. What I can say is that this only happens when I watch Netflix from my TV app, which happens to be the only time I feed the G65 with audio through an optical connection. All other sources is connected through my HD621 with HDMI. I also suspect that this only happens when Netflix is steaming material with surround sound. But I haven't payed enough attention to this detail to be absolutely sure.

Anyone here with experience with this issue and any suggestions on how to resolve this?

Top
#271500 - 2018-01-07 10:45 Re: G65 freezes up occasionally [Re: Snooky]
Registered: 2006-05-03
Posts: 92
S2000 Offline
Hitchhiker
S2000 Offline
Hitchhiker

Registered: 2006-05-03
Posts: 92
Loc: Bournemouth, Dorset, UK
My G65 does this consistently when selecting any analogue source... The response to the front panel goes super slow and the analogue source doesn't work.
Luckily the unit is 100% in digital mode which is how I run mine. Mine clearly has a fault but as it was out just of warranty when I bought it and I only use digital inputs, then I've not bothered to repair it. The only downside is that I can't use MRC as I can't run the calibration (which is how I noticed the fault in the first place)...
My G61R had to be repaired after only a few months with a tuner and volume issue. Disappointing reliability.

If you can't live with it, a trip to your dealer may resolve it before having to return it to M.


Various from vintage to SE
Top
#271515 - 2018-01-07 18:35 Re: G65 freezes up occasionally [Re: S2000]
Registered: 2014-11-15
Posts: 1
GNA1970 Offline
Harmless
GNA1970 Offline
Harmless

Registered: 2014-11-15
Posts: 1
Loc: Liverpool, UK
I received this email from M last week when I enquired about having my G91a fixed...

Unfortunately, we dropped all service support for our G series DVD players in 2016. This decision was not taken lightly and was precipitated by the depletion of many key parts used on these models. We just couldn’t guarantee reliable fixes in the absence of a supply of the relevant parts. We’re sorry to have to give what is likely to be frustrating news.


G91a, 557, B&w cm4
Top
#271517 - 2018-01-07 19:04 Re: G65 freezes up occasionally [Re: S2000]
Registered: 2007-09-17
Posts: 30
Snooky Offline
Harmless
Snooky Offline
Harmless

Registered: 2007-09-17
Posts: 30
I haven't experienced any issue with analog connections. Digital through HDMI works fine too. But DD 5.1 over optical fails with uneven intervals. Seems to happen just as the G65 should detect what kind of audio signal it's receiving. Never experienced this when I set the TV to output 2 ch stereo, or when I play material with no surround sound on Netflix.

So my best guess is that DD 5.1 over optical, at least from this source, can be "confusing" for the G65. Perhaps the signal is of a poor quality? I'll try selecting poor digital source in mconfig for this input and do some more testing. Unfortunately there has been weeks between each time this error occurs, so I won't know for sure for quite some time.

The G65 is under warranty, so I guess I'll contact the dealer too.

Top
#271518 - 2018-01-07 20:28 Re: G65 freezes up occasionally [Re: Snooky]
Registered: 2006-05-03
Posts: 92
S2000 Offline
Hitchhiker
S2000 Offline
Hitchhiker

Registered: 2006-05-03
Posts: 92
Loc: Bournemouth, Dorset, UK
Presumably you've tried a different optical lead and ensured there's no dust?


Various from vintage to SE
Top

Moderator:  Carl, Duncs, ncpl 
Who's Online
2 registered (Carl, Marc Koval), 41 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
GazB, TL101, ThoughtPolice, Sndpnr, PWN
4649 Registered Users
Top Posters (30 Days)
Ratbert 66
3dit0r 52
CMB Integrations - Bruce 43
Ian 28
Martins HiFi 27
Top Posters
VirusKiller 12354
Fiddler 8666
ncpl 8455
Carl 7727
Ian 7494
Forum Stats
4,649 Registered Members
17 Forums
24,983 Topics
255,126 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant