Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Page 1 of 3 1 2 3 >
Topic Options
Rate This Topic
#269800 - 2017-11-13 21:36 Repair of 596 and 588 (DSL-710A)
Registered: 2017-11-13
Posts: 5
Barry_G Offline
Harmless
Barry_G Offline
Harmless

Registered: 2017-11-13
Posts: 5
Loc: Arnsberg, Germany
Hi, in 2011 I bought two DVD-ROM drives (DSL-710A) for my 588 and 596 as a precaution. I wanted to be equipped when the drives had to be changed.

As now the 596 more frequently indicated "No Disc", I installed one of the spare drives. Unfortunately also "No Disc" appeared. Extensive researches on the Internet have shown that the internal firmware of the drives is completely different.

For the 596 the firmware LK18 and for the 588, LO13 is originally programmed. The two new DSL-710A are based on a firmware called LT14 of the supplier company DSL, Korea. Unfortunately I cannot change the new lasers, because the drive shaft is on the other side. Also I can't change the circuit board, because it has slightly different ribbon cables. I do not know how I can get the appropriate firmware into the new drives.

I’ve heard that the laser is a Sanyo SF-HD3S but not sure if this will work. I can’t get it in Germany either. Later DSL-720A and DRL-200 drives have been used.

For now it would be fine to change the laser, because the drive works fine. But I would like to use my “music machines” for a longer period. Does anybody have an idea how I can solve this problem?

Regards Barry_G


551, 556, 504, 562.2, 588, 596 + Orange Audio Filter
B & W Signature 30, Cabasse Jupiter 350 (Sub)
Cabasse Sloop 500
Thorens 147, Revox A-77, Braun C2
Top
#269814 - 2017-11-14 08:35 Re: Repair of 596 and 588 (DSL-710A) [Re: Barry_G]
Registered: 2008-10-11
Posts: 370
Tarik Online content
Hitchhiker
Tarik Online content
Hitchhiker

Registered: 2008-10-11
Posts: 370
Loc: Gloucestershire, UK
Have you tried plugging the replacement drive into a PC to see if it reads discs?

It could be that the replacement is faulty as well.


Lounge: DSP5200, 518
Snug: DSP33 x 5, 518, C61R
Office: M33, 561

Top
#269820 - 2017-11-14 09:24 Re: Repair of 596 and 588 (DSL-710A) [Re: Tarik]
Registered: 2008-10-11
Posts: 370
Tarik Online content
Hitchhiker
Tarik Online content
Hitchhiker

Registered: 2008-10-11
Posts: 370
Loc: Gloucestershire, UK
You could also try flashing the firmware after the drive has been installed.


Lounge: DSP5200, 518
Snug: DSP33 x 5, 518, C61R
Office: M33, 561

Top
#269874 - 2017-11-14 21:26 Re: Repair of 596 and 588 (DSL-710A) [Re: Tarik]
Registered: 2017-11-13
Posts: 5
Barry_G Offline
Harmless
Barry_G Offline
Harmless

Registered: 2017-11-13
Posts: 5
Loc: Arnsberg, Germany
Yes, first I connected the device via RS232 which doesn't work. I took the new drive out and connected it to the computer. It
worked and I was able to find the volume of the wrong firmware in it.

This is what Meridian answered:
Quote:
Like you, if drives with inappropriate firmware come into our possession, we are unable to use them. Our solution was to buy all the refurbished drives we could find which were already loaded with appropriate firmware.

The program “Meridian.exe” is used to configure settings on 500 series surround processors, but it has no provision for accessing the firmware on ROM drives. Please note: the DVS firmware on the drive is completely independent from the firmware loaded to the product via the RS232 socket.

We used some batches of the DRL200 drive in place of the DSL7xx drives over the years. If it has appropriate firmware loaded, it can be used on 588 as well as 596. Some of our DRL200s had a slower eject mechanism, so they could struggle to open the drawer on 800 series players.

We are sorry that this situation has come to pass as we’d like to support all products we’ve ever made. However, commercial realities make this unfeasible.
Isn't there anybody with an idea to make a new drive work inside 596 respective 588?


551, 556, 504, 562.2, 588, 596 + Orange Audio Filter
B & W Signature 30, Cabasse Jupiter 350 (Sub)
Cabasse Sloop 500
Thorens 147, Revox A-77, Braun C2
Top
#272086 - 2018-01-20 13:26 Re: Repair of 596 and 588 (DSL-710A) [Re: Barry_G]
Registered: 2017-11-13
Posts: 5
Barry_G Offline
Harmless
Barry_G Offline
Harmless

Registered: 2017-11-13
Posts: 5
Loc: Arnsberg, Germany
Finally there is a new situation:

I was able to buy two new DRL-200 drives and put them in place. I then still had problems with the RS232 connection. I bought several so called "null modem cables", they did not work. Checking them, I found out, none of them was a real null modem cable. Take care buying the correct cable. Solution was to configure a null modem cable by myself after the following scheme (thanks to Tarik):

female to female

5 4 3 2 1
.9 8 7 6

1 : not connected
2 : 3
3 : 2
4 : 6
5 : 5
6 : not connected
7 : 8
8 : 7
9 : not connected

This works on PC with a RS232 connection both using WIN 7 and WIN 10. (therefore I did not check Ubuntu)
The firmware was immediately on the devices. Everything seems to work nicely again.

I only noticed that the disc is still spinning fast when opening the drawer of the 596. Maybe someone has an idea what is the reason for this and how to influence it?

Regards Barry_G


551, 556, 504, 562.2, 588, 596 + Orange Audio Filter
B & W Signature 30, Cabasse Jupiter 350 (Sub)
Cabasse Sloop 500
Thorens 147, Revox A-77, Braun C2
Top
#272089 - 2018-01-20 14:10 Re: Repair of 596 and 588 (DSL-710A) [Re: Barry_G]
Registered: 2002-08-28
Posts: 4,291
Mr Meridian Offline
President of the Imperial Galactic Government
Mr Meridian Offline
President of the Imperial Galactic Government

Registered: 2002-08-28
Posts: 4,291
Loc: Perthshire, Scotland
If discs are still spinning fast when the tray is opened, that's surely going to cause surface abrasion as they are unsupported on that loader tray?

Would that be where Meridian's own drive firmware was required, to prevent such behaviour? I recall mention some years ago about specific drive firmware in addition to the overall player firmware. Out of interest, where did you manage to source the drives?

Cheers
George

Top
#272101 - 2018-01-20 18:28 Re: Repair of 596 and 588 (DSL-710A) [Re: Mr Meridian]
Registered: 2008-10-11
Posts: 370
Tarik Online content
Hitchhiker
Tarik Online content
Hitchhiker

Registered: 2008-10-11
Posts: 370
Loc: Gloucestershire, UK
Barry_G, Glad I could help you get up and running. Perhaps hitting stop prior to opening the drawer is the work around - not perfect but at least the player is working again.

George, The reply from Meridian further up the thread would seem to indicate that there is no special firmware that they load onto the drive, but that a certain stock drive firmware is required.

Not all DSL-710 or 720 drives will work.

A 710 drive with the LV firmware certainly works, but not sure if there is any impact or compatibility issues around the version numbers.


Lounge: DSP5200, 518
Snug: DSP33 x 5, 518, C61R
Office: M33, 561

Top
#272341 - 2018-01-26 20:55 Re: Repair of 596 and 588 (DSL-710A and DRL-200) [Re: Barry_G]
Registered: 2017-11-13
Posts: 5
Barry_G Offline
Harmless
Barry_G Offline
Harmless

Registered: 2017-11-13
Posts: 5
Loc: Arnsberg, Germany
After exchanging the drives of my 596 and 588 and updating the devices I could notice the following changes:
588 (with DRL-200) needs much longer for reading the CD's. Communication between my other Meridian stuff (see below) via Comms is not the same. To open the drawer needs to push stop first, otherwise CD's will still spin during opening. Display can't be set to track-no. only.

596 (with DRL-200) needs much longer for reading CD's. Display can't be set to track-no. only. Can't be set to standby via remote. After installing a new DSL-710A CD's were recognized much faster. But still communication with my 562V2 is not the same. Display can't be set to track-no. only. Can't be set to standby via remote.
Does anybody have previous firmware, just to test if there is an improvement in the performance?

Kindest regards
Barry_G


551, 556, 504, 562.2, 588, 596 + Orange Audio Filter
B & W Signature 30, Cabasse Jupiter 350 (Sub)
Cabasse Sloop 500
Thorens 147, Revox A-77, Braun C2
Top
#272447 - 2018-01-30 08:52 Re: Repair of 596 and 588 (DSL-710A and DRL-200) [Re: Barry_G]
Registered: 2008-10-11
Posts: 370
Tarik Online content
Hitchhiker
Tarik Online content
Hitchhiker

Registered: 2008-10-11
Posts: 370
Loc: Gloucestershire, UK
With respect to the DSL-710a drive is the drive firmware of the replacement belonging to the same family as the one you replaced?

For example, if the original was LTx.x then the new one should be LTx.x and the numbers the same or higher.


Lounge: DSP5200, 518
Snug: DSP33 x 5, 518, C61R
Office: M33, 561

Top
#273067 - 2018-02-12 21:17 Re: Repair of 596 and 588 (DSL-710A and DRL-200) [Re: Barry_G]
Registered: 2013-11-24
Posts: 21
Bayreuth Offline
Harmless
Bayreuth Offline
Harmless

Registered: 2013-11-24
Posts: 21
Loc: Stockport, Cheshire, UK
Originally Posted By Barry_G
Does anybody have previous firmware, just to test if there is an improvement in the performance?
I have an early 596 still working perfectly with its original drive (fwiw I haven’t even upgraded the 596 firmware; still 1.1).

I have no idea (= haven’t tried to find out) how to check the drive type and firmware version - and have no idea how much disassembly of the 596 would be required to get at the drive. Let me know whether you think I might have something that could be useful to you and if so, what exactly I would need to do!

Paul


priorities: stereo music (primarily 'classical' / choral / opera)
boxes: various 500-series, DACs, G91 (+ non-M e.g. ELS-63)
Top
#273114 - 2018-02-13 15:43 Re: Repair of 596 and 588 (DSL-710A and DRL-200) [Re: Bayreuth]
Registered: 2008-10-11
Posts: 370
Tarik Online content
Hitchhiker
Tarik Online content
Hitchhiker

Registered: 2008-10-11
Posts: 370
Loc: Gloucestershire, UK
The information can be found in two ways:

1) With the 596 in standby repeatedly press the display key and one of the displays will be the drive type.

2) From within the Information section of the on screen menu


Lounge: DSP5200, 518
Snug: DSP33 x 5, 518, C61R
Office: M33, 561

Top
#273147 - 2018-02-14 05:03 Re: Repair of 596 and 588 (DSL-710A and DRL-200) [Re: Tarik]
Registered: 2013-11-24
Posts: 21
Bayreuth Offline
Harmless
Bayreuth Offline
Harmless

Registered: 2013-11-24
Posts: 21
Loc: Stockport, Cheshire, UK
Thanks Tarik.

1)
596 1.1
(Repeatedly pressing Display does not change the info shown.)

2)
Region code
Firmware 1.1
Microcode W-2333
Drive data
DVS-LDR DSL-710A
L013

Paul


priorities: stereo music (primarily 'classical' / choral / opera)
boxes: various 500-series, DACs, G91 (+ non-M e.g. ELS-63)
Top
Page 1 of 3 1 2 3 >

Moderator:  Carl, Duncs, ncpl 
Who's Online
3 registered (GMT, Zanderbarfly, Not'arf), 58 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
Tybot, COTJ, Hualon, ChalkyFingers, HappyHal
4635 Registered Users
Top Posters (30 Days)
3dit0r 87
Ratbert 58
CMB Integrations - Bruce 51
Tarik 37
Awb 28
Top Posters
VirusKiller 12325
Fiddler 8659
ncpl 8436
Carl 7701
Ian 7454
Forum Stats
4,635 Registered Members
17 Forums
24,899 Topics
254,368 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant