Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Topic Options
Rate This Topic
#269743 - 2017-11-12 02:38 G61R flashing logo and ticking sound?
Registered: 2008-11-25
Posts: 3
fritz Offline
Harmless
fritz Offline
Harmless

Registered: 2008-11-25
Posts: 3
Hi there,

I just came home to a G61R with a ticking sound coming from the unit. Similar to when you switch sources but rhythmic - every once second or so. The "Meridian" logo flashes on and off.

When I switch the units off at the mains and start again. I either get it to come on with the "Meridian" Logo solid or it will operate normally for about a minute and then stop and turn off.

Is this a power supply maybe?

Top
#269748 - 2017-11-12 09:52 Re: G61R flashing logo and ticking sound? [Re: fritz]
Registered: 2003-10-04
Posts: 1,987
spinaltap Offline
Knows where his towel is
spinaltap Offline
Knows where his towel is

Registered: 2003-10-04
Posts: 1,987
Loc: Bournville, UK
Very likely.


My Mac can go all the way to XI - Mac user since 1988.
Top

Moderator:  Carl, Duncs, ncpl 
Who's Online
2 registered (Kent in Welly, JimK), 65 Guests and 5 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
YBA_US, Tybot, COTJ, Hualon, ChalkyFingers
4636 Registered Users
Top Posters (30 Days)
3dit0r 100
Ratbert 73
CMB Integrations - Bruce 59
Tarik 38
Jazzmaniac1954 29
Top Posters
VirusKiller 12325
Fiddler 8659
ncpl 8441
Carl 7702
Ian 7458
Forum Stats
4,636 Registered Members
17 Forums
24,910 Topics
254,497 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant