Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Topic Options
Rate This Topic
#232442 - 2015-03-28 22:35 DSP3200 Power Supply Failure
Registered: 2012-09-16
Posts: 495
Huw Offline
Paranoid android
Huw Offline
Paranoid android

Registered: 2012-09-16
Posts: 495
Loc: Farnham Surrey, UK
Just been doing firmware updates on my 3200s - I have two pairs. All went well except for one, which refused to complete the update.

Investigation showed that in the power/re-powering sequence that is required the speaker was not actually re-powering - it was dead!

The little green indicator on the rear flashes momentarily when the power lead is put back in, but then extinguishes immediately. Of course the speaker no longer functions. I checked the fuse but not blown. The mains pins all look good and well aligned.

I removed the back or a quick peek but decided to put it back right away - looked a bit tricky, but must be something to do with the power supply.

Any ideas please?

Thanks regards
Huw


Room1 MS600, G61RSL, HD621, 7K, 5KHC (96/24), 5K (96/24), SW1600, Panasonic plasma, Sony BRD PS3, Humax, M7 Dutch decoder.
Room2 C15, AC200 MS200, 5K2SE, iDock.
Room3 562v, 565, 504, 5Ks & 5KHC 18 bit, MS200, TwinStore, Explorer1, Arcam Solo, Systemdek I920, Ortofon M520. QNAP
Room4 Panasonic 4K LED, Canton DM75 .
Room5 F80, iDock, Explorer 2
Top
#232447 - 2015-03-28 22:45 Re: DSP3200 Power Supply Failure [Re: Huw]
Registered: 2004-08-07
Posts: 7,271
Ian Offline
President of the Imperial Galactic Government
Ian Offline
President of the Imperial Galactic Government

Registered: 2004-08-07
Posts: 7,271
Loc: Surrey, England, UK
I can't remember if it was the 3100 or 3200 that could be bricked when doing a firmware update.


Meridian owner since 1992
DSP5000 96/24, MC200, Prime & PSU, Focal Elear, Explorer 1 & 2, F80, 200/203 and various Sonos.
Top
#232450 - 2015-03-28 23:04 Re: DSP3200 Power Supply Failure [Re: Ian]
Registered: 2004-01-16
Posts: 914
Colin Triggs Offline
Pan-dimensional being
Colin Triggs Offline
Pan-dimensional being

Registered: 2004-01-16
Posts: 914
Loc: Great Yarmouth, Norfolk, UK
The 3100 upgrade to v1.3 is the tricky one.


Cinema: DSP5200HCSL (rear), DSP5200HCSL (rear), DSP8000.2VC (centre) all in storage
Office: 861v8, 800v4, HD621, DSP7200.2, DSP5200HCSL, DSW, DSP3300, C15, Denon 2500BT
Lounge: 861v8, HD621, DSP8000.2, DSP5200HCSL, M6, DSW, 504, Oppo 203
Spare:
Top
#232453 - 2015-03-28 23:13 Re: DSP3200 Power Supply Failure [Re: Colin Triggs]
Registered: 2012-09-16
Posts: 495
Huw Offline
Paranoid android
Huw Offline
Paranoid android

Registered: 2012-09-16
Posts: 495
Loc: Farnham Surrey, UK
Well it looks as though it might be the 3200s too - though the other three worked fine.

Regards Huw


Room1 MS600, G61RSL, HD621, 7K, 5KHC (96/24), 5K (96/24), SW1600, Panasonic plasma, Sony BRD PS3, Humax, M7 Dutch decoder.
Room2 C15, AC200 MS200, 5K2SE, iDock.
Room3 562v, 565, 504, 5Ks & 5KHC 18 bit, MS200, TwinStore, Explorer1, Arcam Solo, Systemdek I920, Ortofon M520. QNAP
Room4 Panasonic 4K LED, Canton DM75 .
Room5 F80, iDock, Explorer 2
Top
#232454 - 2015-03-28 23:36 Re: DSP3200 Power Supply Failure [Re: Huw]
Registered: 2011-03-04
Posts: 41
Tyler Bell Offline
Son of Tintin Mostly harmless
Tyler Bell Offline
Son of Tintin
Mostly harmless

Registered: 2011-03-04
Posts: 41
Loc: Hampshire, UK
I would re try the update a couple of times (in the event you haven't already).


Tyler
Top
#232456 - 2015-03-28 23:59 Re: DSP3200 Power Supply Failure [Re: Tyler Bell]
Registered: 2012-09-16
Posts: 495
Huw Offline
Paranoid android
Huw Offline
Paranoid android

Registered: 2012-09-16
Posts: 495
Loc: Farnham Surrey, UK
Did it a few times but it would not fly. Do you think the non complete update is preventing it powering up?

Once it has lost power it's not possible do the update, because though the SL reads the speaker you can't empower and repower.

I think some serious has gone in the power supply.

What to do?
Regards Huw


Room1 MS600, G61RSL, HD621, 7K, 5KHC (96/24), 5K (96/24), SW1600, Panasonic plasma, Sony BRD PS3, Humax, M7 Dutch decoder.
Room2 C15, AC200 MS200, 5K2SE, iDock.
Room3 562v, 565, 504, 5Ks & 5KHC 18 bit, MS200, TwinStore, Explorer1, Arcam Solo, Systemdek I920, Ortofon M520. QNAP
Room4 Panasonic 4K LED, Canton DM75 .
Room5 F80, iDock, Explorer 2
Top
#232477 - 2015-03-29 11:51 Re: DSP3200 Power Supply Failure [Re: Huw]
Registered: 2004-08-07
Posts: 7,271
Ian Offline
President of the Imperial Galactic Government
Ian Offline
President of the Imperial Galactic Government

Registered: 2004-08-07
Posts: 7,271
Loc: Surrey, England, UK
Sounds like one for the repair shop or back to M via a PP - options will vary on warranty and relationship with PP.


Meridian owner since 1992
DSP5000 96/24, MC200, Prime & PSU, Focal Elear, Explorer 1 & 2, F80, 200/203 and various Sonos.
Top
#232500 - 2015-03-29 18:34 Re: DSP3200 Power Supply Failure [Re: Huw]
Registered: 2011-03-04
Posts: 41
Tyler Bell Offline
Son of Tintin Mostly harmless
Tyler Bell Offline
Son of Tintin
Mostly harmless

Registered: 2011-03-04
Posts: 41
Loc: Hampshire, UK
Are you in a position to test the PS outputs? It does look a bit tight in there though. Anyone else had a dead 3200?


Tyler
Top
#232501 - 2015-03-29 18:37 Re: DSP3200 Power Supply Failure [Re: Tyler Bell]
Registered: 2012-09-16
Posts: 495
Huw Offline
Paranoid android
Huw Offline
Paranoid android

Registered: 2012-09-16
Posts: 495
Loc: Farnham Surrey, UK
I had a quick peek and decided best to leave well alone, because as you say it's all very tight and I might do more damage.

Regards Huw


Room1 MS600, G61RSL, HD621, 7K, 5KHC (96/24), 5K (96/24), SW1600, Panasonic plasma, Sony BRD PS3, Humax, M7 Dutch decoder.
Room2 C15, AC200 MS200, 5K2SE, iDock.
Room3 562v, 565, 504, 5Ks & 5KHC 18 bit, MS200, TwinStore, Explorer1, Arcam Solo, Systemdek I920, Ortofon M520. QNAP
Room4 Panasonic 4K LED, Canton DM75 .
Room5 F80, iDock, Explorer 2
Top
#234702 - 2015-05-08 18:34 Re: DSP3200 Power Supply Failure [Re: Huw]
Registered: 2008-09-12
Posts: 20
Westiebj Offline
Harmless
Westiebj Offline
Harmless

Registered: 2008-09-12
Posts: 20
Loc: London, UK
Any update on this ?

Thanks


Main System :- Audio Research DS200i , Audio Research DAC7, Audio Research PH6, Michel GyroSE, SME309, Ortofon 2M Black,Sonus Faber Guarneri Evolution, Linn Sneaky DS,
Second System :- Meridian Ac200, DSP3200, SB Touch
Headphone system :- Burson 160 DS, Denon AH 7100, SB Touch
Top

Moderator:  Carl, Duncs, ncpl 
Who's Online
8 registered (CMB Integrations - Bruce, Jack D, Carl, Rodders, ChrisLayerUK, Mac147), 51 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
Filipe, Barry_G, 964RS, miguelito, Grandluc
4550 Registered Users
Top Posters (30 Days)
spinaltap 53
CMB Integrations - Bruce 39
Ratbert 37
ChrisLayerUK 28
Gianni 27
Top Posters
VirusKiller 12164
Fiddler 8627
ncpl 8296
Carl 7479
Ian 7271
Forum Stats
4,550 Registered Members
17 Forums
24,107 Topics
248,205 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant