Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Page 1 of 3 1 2 3 >
Topic Options
Rate This Topic
#228303 - 2015-01-18 09:39 Explorer 2 not showing power light but hot
Registered: 2014-04-25
Posts: 87
Jose_Howay Offline
Hitchhiker
Jose_Howay Offline
Hitchhiker

Registered: 2014-04-25
Posts: 87
Loc: Pinole CA, USA
My Explorer 2 was working with no problems, all I did was unplug the USB cable out then tried to use it.

No more power and it feels warm.

Only a week a old serial e200eb


861v4 LPSU, DSP6000 (D6000 originally)upgraded 96/24 with H1212 tweeters, DSP5500HC with Excel tweeter 96/24, M33 rear speakers, Explorer 1 to 861v4-Toslink Roon/Tidal. Oppo BDP80 via IA45 card.
Top
#228310 - 2015-01-18 16:22 Re: Explorer 2 not showing power light but hot [Re: Jose_Howay]
Registered: 2008-05-23
Posts: 7,477
Carl Offline
President of the Imperial Galactic Government
Carl Offline


President of the Imperial Galactic Government

Registered: 2008-05-23
Posts: 7,477
Loc: Central England, UK
Hi,

Sorry to hear this.

I doubt there's much you can do with it, so I'd advise your supplier and ask for it to be replaced with a new one.

Regards,
Carl


861v6+ID40, HD621, 8000.2, 7200HC, 7200, SKYQ Silver, PS3, PDP-LX6090, QNAP TS870-Pro (8*6TB), Roon, iPadAir2.
[In Reserve] C15, MD600 (2*3TB), TwinStore RM (2*2TB)
Top
#228319 - 2015-01-18 20:47 Re: Explorer 2 not showing power light but hot [Re: Carl]
Registered: 2014-04-20
Posts: 61
shiggins Offline
Mostly harmless
shiggins Offline
Mostly harmless

Registered: 2014-04-20
Posts: 61
Loc: Esher, Surrey, UK
Exactly the same happened with mine. Returned it for a replacement (via Amazon) which has been working fine every day since.


Lounge: DSP5000(18bit), DSP5000C, DSP33, 568.1, Quad L-Sub
Bedroom: DSP5000(24bit), Roon
Top
#228464 - 2015-01-21 18:54 Re: Explorer 2 not showing power light but hot [Re: shiggins]
Registered: 2006-03-27
Posts: 26
DennisWaugh Offline
Harmless
DennisWaugh Offline
Harmless

Registered: 2006-03-27
Posts: 26
Loc: Northampton, UK
Same problem here.
Supplier (Russ Andrews) replaced it without issue.


NUC i7, Roon, HQ Player, Lampizator L4G5, Meridian Explorer 2, MRendu + linear PS, EAR V20, Woo Audio WA22, Senn 800, Audeze LCD XC, PMC GB1i.
Top
#228465 - 2015-01-21 18:59 Re: Explorer 2 not showing power light but hot [Re: DennisWaugh]
Registered: 2010-12-09
Posts: 3,070
Ratbert Offline
Hooloovoo
Ratbert Offline
Hooloovoo

Registered: 2010-12-09
Posts: 3,070
Loc: Europe
Seems to be a higher failure rate than the Explorer 1's, or did nobody report in when they failed?

Russ


.
Top
#228497 - 2015-01-21 22:54 Re: Explorer 2 not showing power light but hot [Re: Ratbert]
Registered: 2008-05-23
Posts: 7,477
Carl Offline
President of the Imperial Galactic Government
Carl Offline


President of the Imperial Galactic Government

Registered: 2008-05-23
Posts: 7,477
Loc: Central England, UK
Reported on here:

Explorer 1 failures = 0
Explorer 2 failures = 2

The Explorer 2 is infinitely more unreliable than 1.
OR
Statistically unsound (not enough sample data).

Regards,
Carl wink


861v6+ID40, HD621, 8000.2, 7200HC, 7200, SKYQ Silver, PS3, PDP-LX6090, QNAP TS870-Pro (8*6TB), Roon, iPadAir2.
[In Reserve] C15, MD600 (2*3TB), TwinStore RM (2*2TB)
Top
#228499 - 2015-01-21 23:28 Re: Explorer 2 not showing power light but hot [Re: Carl]
Registered: 2006-11-08
Posts: 3,937
dpstjp Offline
Vogon Civil Servant
dpstjp Offline
Vogon Civil Servant

Registered: 2006-11-08
Posts: 3,937
Loc: London, England
Let's hope you're right on the latter, Carl, otherwise it will become known as "Manufacturing Quality Awful"


Sooloos, Roon, G series (with LPS upgrade), 800 series (with LPS upgrade), HD621, AC200, Prime and PS, DSPs old and new.

Purdeys, Moke, Leica, 'Blad. Only the best.
Top
#228500 - 2015-01-21 23:32 Re: Explorer 2 not showing power light but hot [Re: dpstjp]
Registered: 2009-09-13
Posts: 5,324
Ludwig Offline
President of the Imperial Galactic Government
Ludwig Offline
President of the Imperial Galactic Government

Registered: 2009-09-13
Posts: 5,324
Loc: Europe
Originally Posted By: dpstjp
Let's hope you're right on the latter, Carl, otherwise it will become known as "Manufacturing Quality Awful"

Only by people who are easily swayed by what they read on the internet. wink


Ex-moderator
Sitting room: 818v3, 8kSE
Office: 818v3, Stax SRM-T1, Stax SR404LE
TV room: HD621, 518, D33
Kitchen: MS200, Genelec 6010 actives
Server: Roon/NUC/Touchscreen

Oldest audio file: 1889 Edison cylinder
Top
#228503 - 2015-01-21 23:59 Re: Explorer 2 not showing power light but hot [Re: Carl]
Registered: 2010-12-09
Posts: 3,070
Ratbert Offline
Hooloovoo
Ratbert Offline
Hooloovoo

Registered: 2010-12-09
Posts: 3,070
Loc: Europe
Originally Posted By: Carl
Reported on here:

Explorer 1 failures = 0
Explorer 2 failures = 2

The Explorer 2 is infinitely more unreliable than 1.
OR
Statistically unsound (not enough sample data).

Regards,
Carl wink


I make it 3 if I count the posts on this page, still an unrepresentative sample I agree, but interesting nonetheless.

Russ


.
Top
#228504 - 2015-01-22 00:03 Re: Explorer 2 not showing power light but hot [Re: Ludwig]
Registered: 2006-11-08
Posts: 3,937
dpstjp Offline
Vogon Civil Servant
dpstjp Offline
Vogon Civil Servant

Registered: 2006-11-08
Posts: 3,937
Loc: London, England
Originally Posted By: Ludwig
Only by people who are easily swayed by what they read on the internet. wink
That would explain why "most people think DSD sounds better". You get a lot of that on the Internet.


Sooloos, Roon, G series (with LPS upgrade), 800 series (with LPS upgrade), HD621, AC200, Prime and PS, DSPs old and new.

Purdeys, Moke, Leica, 'Blad. Only the best.
Top
#228505 - 2015-01-22 00:06 Re: Explorer 2 not showing power light but hot [Re: dpstjp]
Registered: 2002-02-14
Posts: 8,295
ncpl Offline
President of the Imperial Galactic Government
ncpl Offline

President of the Imperial Galactic Government

Registered: 2002-02-14
Posts: 8,295
Loc: Surrey, UK
The issue is of course that the population that have no issue do not post about it. Something about 'O-level sets theory' is forcing it's way into my head...


Rgds,
Nick

#15SE
Top
#228506 - 2015-01-22 00:13 Re: Explorer 2 not showing power light but hot [Re: ncpl]
Registered: 2009-09-13
Posts: 5,324
Ludwig Offline
President of the Imperial Galactic Government
Ludwig Offline
President of the Imperial Galactic Government

Registered: 2009-09-13
Posts: 5,324
Loc: Europe
If it helps the statistics, I stepped on my Explorer1 hard enough for there to be a crunching sound, and it still works perfectly. crazy


Ex-moderator
Sitting room: 818v3, 8kSE
Office: 818v3, Stax SRM-T1, Stax SR404LE
TV room: HD621, 518, D33
Kitchen: MS200, Genelec 6010 actives
Server: Roon/NUC/Touchscreen

Oldest audio file: 1889 Edison cylinder
Top
Page 1 of 3 1 2 3 >

Moderator:  Carl, Duncs, ncpl 
Who's Online
12 registered (Colin Triggs, CMB Integrations - Bruce, Altus, Hector, Gianni, Bobfett), 52 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
Barry_G, 964RS, miguelito, Grandluc, ZekeTheWeak
4549 Registered Users
Top Posters (30 Days)
spinaltap 50
CMB Integrations - Bruce 39
Ratbert 38
Gianni 38
RobertW 37
Top Posters
VirusKiller 12164
Fiddler 8627
ncpl 8295
Carl 7477
Ian 7270
Forum Stats
4,549 Registered Members
17 Forums
24,082 Topics
248,050 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant