Google Search  |  Meridian Systems  |  Meridian Streaming  |  Restaurant  |  WiKi  |  Duncan's Meridian Info  |  Board Rules  |  Restaurant Rules
Topic Options
Rate This Topic
#159961 - 2012-02-03 20:19 556 Power-Amp Help
Registered: 2010-01-21
Posts: 36
JamesBrennan4 Offline
Harmless
JamesBrennan4 Offline
Harmless

Registered: 2010-01-21
Posts: 36
Loc: Florida, USA
I have just acquired a 556 power-amp, the amp is functioning fine, but heatsinks remain cold.

How do I remove the top cover?
Are there any bias current or output balance adjustments.
Is it possible to obtain a schematic?


508.20, 501, 541, 561, 505, 555, 556, 557, Allison IC-20
Top
#160026 - 2012-02-05 05:58 Re: 556 Power-Amp Help [Re: JamesBrennan4]
Registered: 2004-12-09
Posts: 6,191
ChrisLayerUK Online content
President of the Imperial Galactic Government
ChrisLayerUK Online content
President of the Imperial Galactic Government

Registered: 2004-12-09
Posts: 6,191
Loc: Colchester, Essex, UK
Hi, if the heatsinks are cold and it is running well, I don't see a problem. The heatsinks are designed to dissipate heat generated so it looks like you are in a very well ventilated position or you are not driving the amp very hard.

Turn it up and see what happens.

You may want to list what speakers you are driving with it.

Just thoughts and a "Bump" for you. Enjoy, Chris smile


No 18 in the Hall of fame smile I have simple tastes; I am content to settle for the best: GIK monster bass panels, rear wall.
MC200 500GB, QNAP TVS 471i3. Roon into 2 MS200's. Explorer 2. Bluesound Pulse 2 and Mini. 596 v1.89.2, 518, G61R, M60.2 Rosewood, M33C, M33 Rears, M1500 Sub, Foxsat HD, Sony Blu Ray, Pioneer 5090, 2 Chromecast's for LRB videos.
Top
#160070 - 2012-02-05 14:13 Re: 556 Power-Amp Help [Re: JamesBrennan4]
Registered: 2003-09-22
Posts: 392
MarkS Offline
Hitchhiker
MarkS Offline
Hitchhiker

Registered: 2003-09-22
Posts: 392
Loc: Wiltshire, England
I used to have a 556, and the heat sinks on mine remained cool.

Mark S

Top
#160081 - 2012-02-05 16:54 Re: 556 Power-Amp Help [Re: MarkS]
Registered: 2010-01-21
Posts: 36
JamesBrennan4 Offline
Harmless
JamesBrennan4 Offline
Harmless

Registered: 2010-01-21
Posts: 36
Loc: Florida, USA
Thank you Chris and Mark for your comments.

Amplifier is driving a pair of Definitive Technology Mythos ST SuperTower (Floor-standing ultra-performance loudspeaker with built-in powered subwoofers).

Sensitivity :93 dB
Internal Subwoofer Amplifier Power :300 watts

Room dimensions are ~ 20' x 22' x 12' high.

Since speakers include subwoofer amplifier, I would agree with both of you that I am not driving amplifier hard.

Rest of system is 508.20 and 541.

Would still like to remove top glass cover and take look at the beautiful craftsmanship. Any guidance or hints would be gladly appreciated.


508.20, 501, 541, 561, 505, 555, 556, 557, Allison IC-20
Top

Moderator:  Carl, Duncs, ncpl 
Who's Online
10 registered (Kswanson, Njal, Jon Raines, MI', AudioImages - Rick, Gianni), 36 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
BodgerBen, Southall1998, Nate, Sting, SaxMan
4590 Registered Users
Top Posters (30 Days)
CMB Integrations - Bruce 48
Tarik 47
Ratbert 39
Carl 36
Nstzya 35
Top Posters
VirusKiller 12275
Fiddler 8668
ncpl 8393
Carl 7609
Ian 7394
Forum Stats
4,590 Registered Members
17 Forums
24,477 Topics
251,418 Posts

Most users ever online: 211 @ 2015-05-05 14:40
Meridian  |  Media Centre  |  Support  |  Firmware Release Notes  |  RSS Systems  |  RSS Streaming  |  RSS Restaurant